CiviCRM

CiviCRM Stripe 1.9.1 released. Wordpress backend contrib fix, graceful no-email found error handling

Release 1.9.1 is mostly for the auto-packager to pick it up (for real this time), but includes a fix for a potential issue in Wordpress when doing a backend contribution.

Fixes:

  • More graceful search for the 'email' field on a contribution.
  • Fall back to looking up the contact ID, apparent issue on Wordpress backend contribs.
  • Catch error & display clear message when no email was found, instead of trying to query empty value.

https://github.com/drastik/com.drastikbydesign.stripe/releases/tag/1.9.1

New update for CiviCRM Stripe

(Finally, I know right)

This update also lives in the CiviCRM repos, so 4.4 users can grab it from "Manage Extensions" again.  (Delete the old one in your civicrm extensions directory if you had one straight from github).

Here's the git log:

Update for CiviCRM 4.4
    -Fix amount issue from github: https://github.com/drastik/civicrm_stripe/issues/18
    -Fix BillingBlock.tpl issues (cvv image, credit cards image)
    -New error message report if there was a silent error (can be found in stripe.com account logs

 

Review: CiviCRM Cookbook by Tony Horrocks

Having not thoroughly used the CiviCRM interface since CiviCRM 2, it's easy to get lost in all the new features. Being a CiviCRM extension developer, getting lost stinks.

Now instead of feeling my way around blind, I have a great guide to the interface. It's not just simple interface usage mind you, yes it does cover the basics that the end user / client admin might use, but also dives into the really advanced interfaces in Civi.

CiviCRM Stripe Payment Processor

I was given the wonderful opportunity to build the Stripe -> CiviCRM integration recently and I must say, I enjoyed working with their API more than any I've worked with before (other than Drupal!).
Please use this post as a feature/bug/support queue for now.

Fully Qualified Name: com.drastikbydesign.payment.stripe

Stripe Payment Processor for CiviCRM.
CiviCRM 4.1 and below requires a supporting CMS module:
Drupal:  http://drupal.org/project/civicrm_stripe
Joomla: TBD
Wordpress:  TBD

More details in README.
Readme @: https://github.com/drastik/civicrm_stripe

http://civicrm.org/extensions/stripe-payment-processor